Chef 0.9.16 and Ohai 0.6.2 Debian packages available

Deb packages for Chef 0.9.16 and Ohai 0.6.2, as well as the necessary dependencies that are not included in the distributions, have been uploaded to the Debian repository on apt.opscode.com. Instructions regarding how to use this repository can be found on the wiki.

This update provides packages for the distribution releases listed below. Our packaging plans are to continue supporting the most recent LTS of Ubuntu and above, as well as the current stable Debian release and above. We’ll be testing Ubuntu 11.04 (Natty) shortly.

  • Ubuntu 10.04 LTS (Lucid)
  • Ubuntu 10.10 (Maverick)
  • Debian stable (Squeeze)
  • Debian testing (Wheezy)
  • Debian unstable (Sid)

Packaging is underway for Chef 0.10 dependencies. As previously noted, we plan to add additional repositories on our apt server by tacking “-0.10” to the end of the codename, thus allowing users to choose if they want to install 0.9 or 0.10 deb packages by using the respective codename in their sources.list. Chef 0.9 will continue to be served by the bare codename, such as “lucid” whereas 0.10 will be under “lucid-0.10”. We’ll keep you up to date as we make progress on this task.